System Issues preventing page loads
Incident Report for Trakstar Hire
Resolved
This issue has been resolved. If you face any further problems, please reach out to us at support@recruiterbox.com.
Posted Oct 14, 2020 - 07:54 PDT
Monitoring
We have put in a fix for the system issues, and are monitoring the results. You may continue to see an impact as the system continues to correct itself.
Posted Oct 14, 2020 - 06:59 PDT
Identified
We have identified an issue that is impacting page loads for the system. This may prevent navigation through the site, or logging in. We are putting a fix in now, and will update as soon as we know more.

If you have further questions in the meantime you can reach us at support@recruiterbox.com.
Posted Oct 14, 2020 - 06:50 PDT
This incident affected: Trakstar Hire (Application).