Error when accessing the system
Incident Report for Trakstar Hire
Resolved
This issue is resolved. If you face any further problems, please reach out to our team at support@recruiterbox.com
Posted Apr 15, 2021 - 06:16 PDT
Monitoring
We have put a fix in place, and are monitoring the results.
Posted Apr 15, 2021 - 06:00 PDT
Identified
We have found an issue when accessing the system. You may see error messages when first logging in, or while navigating our system. Our team has a fix, and are working on deploying this.
Posted Apr 15, 2021 - 05:34 PDT
This incident affected: Trakstar Hire (Application).