System Slowness
Incident Report for Trakstar Hire
Resolved
The system issues seem to be resolved. If you face any further issues, reach out at hire@trakstar.com
Posted Aug 03, 2021 - 06:52 PDT
Monitoring
The system slowness seems to be resolving - we're monitoring to make sure.
Posted Aug 03, 2021 - 06:43 PDT
Investigating
We are currently investigating system slowness. Our team is working towards a fix.
Posted Aug 03, 2021 - 06:27 PDT
This incident affected: Trakstar Hire Application.