System Wide Issue
Incident Report for Trakstar Hire
Resolved
This issue is resolved. Please refresh, and if you're still facing issues reach out at hire@trakstar.com.
Posted Aug 12, 2021 - 06:59 PDT
Monitoring
We have put in a fix, and are monitoring the results. Please refresh, and if you're still facing issues reach out at hire@trakstar.com.
Posted Aug 12, 2021 - 06:48 PDT
Investigating
We are currently investigating a system wide issue which is causing system slowness, or inability to log in. Our team is working on a fix.
Posted Aug 12, 2021 - 06:36 PDT
This incident affected: Trakstar Hire Application.