Application Connection Issues
Incident Report for Recruiterbox
Resolved
All should be loading and soaring back to normal now! If you have any questions please feel free to give us a shout at support@recruiterbox.com! Happy Weekend!
Posted 6 months ago. Apr 21, 2018 - 15:07 UTC
Monitoring
Our team has found the root cause of the slowness. We have put in place a fix, and we're monitoring the speed of the system.

We are still seeing some slowness in the Candidate Dashboard, and we will keep an eye on this.

If you're experiencing any other issues, please reach out to us at support@recruiterbox.com.
Posted 6 months ago. Apr 20, 2018 - 17:47 UTC
Identified
Our awesome team is still working on the sluggish-ness. It seems to be a bit better, but we're watching it, and figuring out what's up.

Do reach out if you need us in the meantime - support@recruiterbox.com.
Posted 6 months ago. Apr 20, 2018 - 16:16 UTC
Investigating
It's not just you...we're currently seeing the connection issues too. We have our awesome team on it, and they're digging in to what is happening.

Currently you may be seeing sluggish load times, or the page stuck at the initial "Loading" message.

We'll update as soon as we know more! If you need us in the meantime, we're always available - support@recruiterbox.com.
Posted 6 months ago. Apr 20, 2018 - 15:14 UTC